WSPRnet.org Site

Topic / Topic starter Repliessort ascending Last post
Normal topic Bad spot on 60m
by zs6sgm » Thu, 2014/11/20 - 09:48
0
by zs6sgm
Thu, 2014/11/20 - 09:48
Normal topic US4RVO WRONG LOCATOR
by G8BVJ » Tue, 2011/07/19 - 17:51
0
by G8BVJ
Tue, 2011/07/19 - 17:51
Normal topic Wrong band spots
by G7FYO » Thu, 2014/03/06 - 14:38
0
by G7FYO
Thu, 2014/03/06 - 14:38
Normal topic uploaded spots error 80/160m
by GM4OAS » Thu, 2015/02/05 - 12:46
0
by GM4OAS
Thu, 2015/02/05 - 12:46
Normal topic Wrong band
by PA2ET » Wed, 2010/05/19 - 16:48
0
by PA2ET
Wed, 2010/05/19 - 16:48
Normal topic false decodes
by G0NBD » Fri, 2009/01/30 - 23:44
0
by G0NBD
Fri, 2009/01/30 - 23:44
Normal topic Wrong Band
by R3LW » Tue, 2015/06/16 - 20:47
0
by R3LW
Tue, 2015/06/16 - 20:48
Normal topic wrong spots, sorry
by LA3JJ » Fri, 2012/06/01 - 03:38
0
by LA3JJ
Fri, 2012/06/01 - 03:38
Normal topic Reported Wrong Band
by SWL_VK4 » Wed, 2010/10/06 - 05:25
0
by SWL_VK4
Wed, 2010/10/06 - 05:25
Normal topic Wrong band report
by VK4ZBV » Sun, 2017/12/10 - 22:20
0
by VK4ZBV
Sun, 2017/12/10 - 22:20
Normal topic Wrong band
by KE7KRF » Tue, 2016/01/19 - 19:12
0
by KE7KRF
Tue, 2016/01/19 - 19:12
Normal topic Not 4m should be 10m - apologies
by G0MJI » Mon, 2012/10/29 - 16:58
0
by G0MJI
Mon, 2012/10/29 - 16:59
Normal topic Wrong band reports
by g4cao » Wed, 2014/03/26 - 20:33
0
by g4cao
Wed, 2014/03/26 - 22:59
New posts
No new posts
Hot topic with new posts
Hot topic without new posts
Sticky topic
Locked topic