WSPR 3.00 , Elecraft K3, Ubuntu 10.04 LTS 64 bit and SignalLink USB sound card

1 post / 0 new
W0AY
Offline
Last seen: 8 hours 38 min ago
Joined: 2011/11/15 - 20:22
WSPR 3.00 , Elecraft K3, Ubuntu 10.04 LTS 64 bit and SignalLink USB sound card
AttachmentSize
Image icon ScreenParameters.png34.2 KB

I have WSPR 3.00_r2415 installed in my Ubuntu 10.04 LTS x86_64 which "connects" to my Elecraft K3 via a SignalLink USB "sound card". RS232 commands from WSPR3.0 flow to the K3 via a USB/Com port Dongle which I purchased from Elecraft. ( 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART))

1. Since my Ubuntu Linux installation is 64bit, I wasn't able to install the .386 deb file. I received a "Wrong Architecture" error when I attempted dpkg on the naked .386 .deb file. So in a terminal, I made sure I was in my home directory with 'cd $HOME' followed by 'sudo dpkg --instdir=. --force-architechture -i wspr_2.11r2263_i386.deb' so the 386 program would run in my 64 bit installation. For this to work, you need have previously installed the package "ia32-libs". This installs 32 bit runtime libraries compatible with your amd64 or ia64 debian installation.

2. After experimenting and configuring, my final WSPR 3.0 Station Parameters look like the attached screen shot.

3. If you start wspr in a terminal, you may see the repeated error message "Error bt_audio_service_open: connect() failed: Connection refused (111)". This is somehow caused by the "bluez-alsa" package. Use synaptic or sudo apt-get remove bluez-alsa and the error disappears!