Another WSPR and Linux

1 post / 0 new
dh5ym
Offline
Last seen: 9 years 2 days ago
Joined: 2009/04/22 - 15:36
Another WSPR and Linux

Here the steps that lead to successfully starting WSPR 1.1 on my Ubuntu 8.10 system:

From OH2GQCs website i got the information how to checkout the sources (You need SVN installed before):

mkdir src
cd src
svn checkout svn://svn.berlios.de/wsjt
cd wsjt/branches/wspr

now you need a couple of packages necessary to compile/run WSPR. The list was previously published here...
python2.5-dev
python-numpy 1.1.1 (no problems with this version here yet)
python-imaging tk
python-pmw
libportaudio2
libportaudio-dev
portaudio19-dev
libsamplerate0-dev

subversion
subversion tools
python-svn

In addition the gfortran compiler seems not valid for WSPR. Download the g95 debian package and install it. This compiler will work.

When i tested the revision of the trunk of the WSJT tree was something 11xx. There i got several error messages after typing make. Therefore i reverted the directory of WSPR back to r1045 which was said to be ok. I did this in the WSPR directory with the command:

svn up -r 1045

After that a ./configure should work and after that make should do all the compile stuff.

After that start WSPR with the command:

python wspr.py

That worked for me on my Kubuntu 8.10 system. Surprisingly the version number when starting WSPR was not 1045 but 1042 ;)

regards
Mario, DH5YM